Ethereum delay

Started
Lasted 7h 59min
MEDIUM

Updates

RESOLVED

lasted 7h 59min

The issue has been resolved.

MONITORING

2h 24min earlier

A fix has been implemented and we are monitoring the results.

INVESTIGATING

5h 35min earlier

We are experiencing a temporary delay with our Ethereum collectors. Our team is actively investigating the root cause and will share an update shortly.