BNB Block Data S3 Delivery Delay

Incident Report for Amberdata

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 19:53 UTC

Investigating

We are currently experiencing delays in the S3 delivery of BNB block data (block metadata). Our team is actively investigating the issue and will provide updates as soon as possible.
Posted Jun 02, 2025 - 15:29 UTC
This incident affected: S3 Deliveries.